System Slowness
Incident Report for SurePrep
Resolved
The system slowness has been resolved. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Mar 17, 2023 - 04:27 PDT
Investigating
Some customers are reporting slowness in SPbinder and verification wizards. SurePrep engineers are investigating. Incident updates will be posted here: https://status.sureprep.com.
Posted Mar 16, 2023 - 15:01 PDT
This incident affected: SPbinder and 1040SCAN Review Wizard.