FileRoom Connectivity Issue
Incident Report for SurePrep
Resolved
The FileRoom Connectivity Issue has been resolved. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Mar 23, 2023 - 16:52 PDT
Investigating
Some customers are reporting system slowness and/or a 500 internal server error in FileRoom. SurePrep engineers are investigating. Incident updates will be posted here: https://status.sureprep.com.
Posted Mar 23, 2023 - 16:23 PDT
This incident affected: FileRoom.