SurePrep System Performance Issues
Incident Report for SurePrep
Postmortem

Incident Description: On September 7, 2021, IBM Network Specialists were alerted by monitoring to packet loss across multiple MZRs over the frontend and backend networks and began investigating. Initial troubleshooting identified a change made to the network to
return a backbone transport circuit into production contained an error that resulted in traffic congestion on the backbone network. IBM Network Specialists rolled back the changes, however the routes took time to fully propagate through the backbone network. Packet loss and high latency cleared once routing changes fully propagated through the network, later in the day on September 7, 2021.

Root Cause: A change made to the network to return a backbone transport circuit into production contained an error. IBM Network Specialists have identified gaps in both the creation and the review of scheduled changes, which contributed to this service impact.

Future Actions: The IBM Cloud team has analyzed this incident for areas of improvement, including issue detection, identification and future mitigation. In order to prevent this type of issue of recurring, IBM Network Specialists have updated these elements of the change process.

Posted Sep 16, 2021 - 08:12 PDT

Resolved
The system performance issues have been resolved. We continue to closely monitor the situation. We are working with our cloud service provider to get a root cause analysis of the performance issues and a post-mortem will be added once those details are finalized. If the system status changes, incident updates will be posted here: https://status.sureprep.com
Posted Sep 07, 2021 - 10:20 PDT
Monitoring
We're seeing improvements in the system performance issues. SurePrep engineers continue to investigate and monitor. Incident updates will be posted here as they become available: https://status.sureprep.com/
Posted Sep 07, 2021 - 09:32 PDT
Investigating
Some customers are reporting system performance issues. SurePrep engineers are investigating. Incident updates will be posted here as they become available: https://status.sureprep.com/
Posted Sep 07, 2021 - 09:10 PDT
This incident affected: FileRoom, SPbinder, 1040SCAN Review Wizard, API, TaxCaddy (TaxCaddy Dashboard), and Integrations (GoSystem Tax Integration, GoFileRoom Integration, CCH Axcess Tax Integration, CCH Global fx Tax Integration, Lacerte Tax Integration, UltraTax Integration, ProSystem fx Tax Integration).