SurePrep Help Center
Incident Report for SurePrep
Resolved
The SurePrep Help Center issue has been resolved.
Posted about 1 year ago. Jun 20, 2018 - 06:25 PDT
Investigating
Customers are reporting that they are unable to access the SurePrep Help Center from FileRoom. We are investigating and incident updates will be posted here as we get them. If you are unable to access the SurePrep Help Center and you need to create a support ticket please send your requests to support@sureprep.com.
Posted about 1 year ago. Jun 19, 2018 - 08:59 PDT
This incident affected: Third Party Services (Zendesk (SurePrep Support Ticketing System and Help Center)).