Errors while opening SPbinder
Incident Report for SurePrep
Resolved
The issue causing SPbinder errors has been resolved. We continue to monitor the situation. Updates will be posted here if there are changes to the system status - https://status.sureprep.com
Posted Mar 18, 2024 - 09:46 PDT
Investigating
Some customers are reporting errors when opening SPbinder. SurePrep engineers are investigating at this time. Incident updates will be posted here: https://status.sureprep.com.
Posted Mar 18, 2024 - 08:37 PDT
This incident affected: SPbinder.