Unable to toggle to TaxCaddy
Incident Report for SurePrep
Resolved
SurePrep teams have implemented fixes and have not seen recurrence of the issues as we have been monitoring them since the changes. If you continue to encounter any "Oops" errors or similar, please contact SurePrep Support for assistance.
Posted Mar 28, 2024 - 13:11 PDT
Update
Our engineers continue to monitor the system status after implementing the fix. Incident updates will be posted at https://status.sureprep.com.
Posted Mar 28, 2024 - 11:25 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2024 - 09:40 PDT
Investigating
We are aware that customers are experiencing issues when accessing cpa.taxcaddy.com. Our engineering team is currently working to restore full access and we will provide an update as soon as we have more information. Customers are advised to refresh their screen as a first step to overcome this issue in the meantime.
Posted Mar 28, 2024 - 09:09 PDT
This incident affected: TaxCaddy (TaxCaddy Dashboard).