FileRoom Issue
Incident Report for SurePrep
Resolved
The FileRoom Issue has been resolved. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Mar 26, 2023 - 09:15 PDT
Investigating
Some customers are reporting issues viewing binders in FileRoom. SurePrep engineers are investigating. Incident updates will be posted here: https://status.sureprep.com.
Posted Mar 26, 2023 - 08:24 PDT
This incident affected: FileRoom.