Errors working in SPbinder
Incident Report for SurePrep
Postmortem

At approximately 2:00 AM PST Saturday morning on February 15th, a primary storage server became unresponsive despite the best efforts of SurePrep engineers to interact with the machine. The situation was escalated to IBM data center support, and ultimately the machine was restarted. The restart resulted in the loss of a key Microsoft REFS volume containing SPbinder workpaper images, a result that is still under analysis by Microsoft Support and Development.

As soon as SurePrep engineers determined the scope of the event, they began provisioning new storage and completed that at approximately 8:30 AM PST, enabling the ongoing submission of new binders. Once the new storage was in place, SurePrep engineers began the process of transferring binder files from existing warm storage to the new live storage.

This transfer process took longer than anticipated, a condition especially true for without-leads binders due to their more complex internal data and file structures. Once a binder’s files completed this transfer process, they became viewable again in SPbinder.

In response, we have begun configuring a hot-failover storage strategy for the primary file systems to reduce future recovery time to minutes. In addition, we are partnering with Microsoft to understand and resolve the core server issue and to evaluate different infrastructure strategies. All existing back-up systems are up and running and all data and files continue to be protected.

Posted Mar 13, 2020 - 18:01 PDT

Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 17:55 PDT
Update
Access has been restored to 2018 binders without leadsheets. The incident is fully resolved. Postmortem to follow.
Posted Mar 13, 2020 - 17:54 PDT
Update
We are continuing to monitor for any further issues.
Posted Feb 25, 2020 - 12:36 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 25, 2020 - 12:35 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 23, 2020 - 06:07 PST
Update
Access has been restored to 2019 binders without leadsheets that were submitted before 8 AM Pacific on Saturday. We continue working to restore access to 2018 and prior year binders without leadsheets. Further updates will be posted here as they become available: https://status.sureprep.com/
Posted Feb 20, 2020 - 16:15 PST
Update
We continue working to restore access to binders without leadsheets that were submitted before 8 AM Pacific on Saturday. Additionally, to give customers a proactive option, owners of binders without leadsheets recently received a system-generated email containing a list of binder files and action required to restore the files. A summary of that email can be found in the following Help Center article: https://helpcenter.sureprep.com/hc/en-us/articles/360043560693

Further updates will be posted here as they become available: https://status.sureprep.com/
Posted Feb 18, 2020 - 14:15 PST
Update
Access to 2018 tax year binders with leadsheets has been restored. We are working to restore access to 2017 and prior tax year binders with leadsheets. Further updates will be posted here as they become available.
Posted Feb 18, 2020 - 03:24 PST
Update
We are still working to fully restore access to 2018 tax year binders with leadsheets and we should have that completed in the next few hours. Further updates will be posted here as they become available.
Posted Feb 17, 2020 - 16:28 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 17, 2020 - 07:12 PST
Update
SurePrep encountered a storage device failure early Saturday morning. Our primary file storage server (volumes hosted on a RAID Array) became non-responsive and its files inaccessible. This was purely a storage system failure and not a security incident. There was no security breach of any of our systems.

At approximately 8 AM Pacific on Saturday, we stood up a new primary file storage server so binders submitted after that time should be accessible. For 2019 binders with leadsheets that were submitted before 8 AM Pacific on Saturday, we restored files from backup so those binders should be accessible. 2018 binders with leadsheets should be restored from backup by this afternoon. 2017 and earlier binders with leadsheets will be restored soon.

For binders without leadsheets that were submitted before 8 AM Pacific on Saturday, customers will need to take specific action. The binder needs to be opened by the last person who opened the binder before the incident. Once that’s done, the binder will be accessible to all users. When a user opens a binder without leadsheets, if the files aren’t available, they will see an “Error in download” message stating “Error occurred while downloading the file(s) listed below.” Contained in that error message is the name of the person who last opened the binder. Once that person opens the binder from the same computer used to open it before, the files and binder will sync and the binder will be accessible to all other users.

For binders that were submitted but never opened, some might need to be deleted and resubmitted. This morning, our support team will reach out to users who submitted binders that need to be deleted and resubmitted.

Further updates will be posted here as they become available.
Posted Feb 17, 2020 - 06:58 PST
Update
We are preparing a detailed explanation and instructions for customers still experiencing SPbinder errors. Those instructions will be posted here in the next hour.
Posted Feb 17, 2020 - 06:07 PST
Update
Our IT and Operations teams continue to make progress towards a full resolution of the SPbinder issues that are causing errors for some customers. Incident updates will be posted here as they become available.
Posted Feb 17, 2020 - 03:44 PST
Update
We continue to make progress towards a full resolution of the SPbinder issues that are causing errors for some customers. Incident updates will be posted here as they become available.
Posted Feb 16, 2020 - 18:15 PST
Update
We continue to mitigate the issues causing some customers to see errors when opening binders. Incident updates will be posted here as they become available.
Posted Feb 16, 2020 - 15:09 PST
Update
Some customers are still experiencing errors opening 2019 binders. Our IT and Operations teams continue working to restore full access to all tax years. Updates will be posted here as soon as they become available.
Posted Feb 16, 2020 - 11:38 PST
Monitoring
Some customers are still experiencing errors opening 2019 binders. Our IT and Operations teams are working to restore access. Updates will be posted here as soon as they become available.
Posted Feb 16, 2020 - 09:41 PST
This incident affected: SPbinder and 1040SCAN Review Wizard.