System Slowness
Incident Report for SurePrep
Resolved
The system slowness has been resolved. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Mar 29, 2023 - 14:15 PDT
Investigating
Some customers are reporting slowness when opening binders. SurePrep engineers are investigating. Incident updates will be posted here: https://status.sureprep.com
Posted Mar 29, 2023 - 10:58 PDT
This incident affected: SPbinder and 1040SCAN Review Wizard.