Customer Support Phone System Issue
Incident Report for SurePrep
Resolved
The SurePrep Customer Support phone system issue has been resolved. We continue to closely monitor the situation. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Apr 22, 2024 - 10:28 PDT
Investigating
Some customers are reporting difficulties when calling SurePrep Customer Support. We are working to resolve the issue as soon as possible. Until the issue is resolved please use the live chat in the Help Center or email support@sureprep.com. Incident updates will be posted here as they become available: https://status.sureprep.com.
Posted Apr 22, 2024 - 08:46 PDT
This incident affected: Third Party Services (Zendesk (SurePrep Support Ticketing System and Help Center)).