Error When Accessing the SurePrep Customer Help Center
Incident Report for SurePrep
Resolved
The issue that caused some customers to receive an error message when attempting to access the SurePrep Customer Help Center from FileRoom has been resolved. We continue to closely monitor the situation. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Oct 20, 2020 - 11:07 PDT
Investigating
Some customers are reporting an error when attempting to access the SurePrep Customer Help Center from FileRoom. Our engineers are investigating. Incident updates will be posted here as they become available: https://status.sureprep.com/
Posted Oct 20, 2020 - 09:23 PDT
This incident affected: Third Party Services (Zendesk (SurePrep Support Ticketing System and Help Center)).