All Systems Operational

About This Site

Welcome to SurePrep's home for system status information. Here you'll find current and historical data on system performance and metrics. If there are any service interruptions, an incident will be reported here. Click on the blue SUBSCRIBE TO UPDATES button above to be notified via email and/or sms as soon as there is a change in system performance or planned system maintenance. Please be aware, after subscribing you will receive a confirmation email.

FileRoom Operational
90 days ago
100.0 % uptime
Today
SPbinder Operational
90 days ago
100.0 % uptime
Today
1040SCAN Review Wizard Operational
90 days ago
100.0 % uptime
Today
Reviewer Dashboard Operational
90 days ago
100.0 % uptime
Today
TaxCaddy Operational
90 days ago
99.99 % uptime
Today
TaxCaddy Dashboard Operational
90 days ago
100.0 % uptime
Today
TaxCaddy Email Notifications Operational
90 days ago
100.0 % uptime
Today
TaxCaddy Taxpayer iOS App Operational
90 days ago
100.0 % uptime
Today
TaxCaddy Taxpayer Android App Operational
90 days ago
100.0 % uptime
Today
TaxCaddy Taxpayer Browser-based Portal Operational
90 days ago
99.98 % uptime
Today
API Operational
90 days ago
100.0 % uptime
Today
Integrations Operational
90 days ago
100.0 % uptime
Today
GoSystem Tax Integration Operational
90 days ago
100.0 % uptime
Today
GoFileRoom Integration Operational
90 days ago
100.0 % uptime
Today
CCH Axcess Tax Integration Operational
90 days ago
100.0 % uptime
Today
CCH Global fx Tax Integration Operational
90 days ago
100.0 % uptime
Today
Lacerte Tax Integration Operational
90 days ago
100.0 % uptime
Today
UltraTax Integration Operational
90 days ago
100.0 % uptime
Today
ProSystem fx Tax Integration Operational
90 days ago
100.0 % uptime
Today
Third Party Services Operational
90 days ago
100.0 % uptime
Today
Zendesk (SurePrep Support Ticketing System and Help Center) Operational
90 days ago
100.0 % uptime
Today
Twilio (Two-Factor Authentication) Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Apr 26, 2024

No incidents reported today.

Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024
Resolved - The SurePrep Customer Support phone system issue has been resolved. We continue to closely monitor the situation. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Apr 22, 10:28 PDT
Investigating - Some customers are reporting difficulties when calling SurePrep Customer Support. We are working to resolve the issue as soon as possible. Until the issue is resolved please use the live chat in the Help Center or email support@sureprep.com. Incident updates will be posted here as they become available: https://status.sureprep.com.
Apr 22, 08:46 PDT
Apr 21, 2024

No incidents reported.

Apr 20, 2024

No incidents reported.

Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.