System Slowness
Incident Report for SurePrep
Resolved
The system slowness has been resolved. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Mar 22, 2023 - 16:51 PDT
Investigating
Some customers are reporting system slowness. SurePrep engineers are investigating. Incident updates will be posted here: https://status.sureprep.com.
Posted Mar 22, 2023 - 14:00 PDT
This incident affected: SPbinder and 1040SCAN Review Wizard.