Planned TaxCaddy Client Management Update
Incident Report for SurePrep
Resolved
The "I WANT TO MANAGE" feature in Client Management is now enabled. If the status changes, updates will posted here: https://status.sureprep.com/
Posted Jan 07, 2022 - 14:01 PST
Identified
TaxCaddy's Client Management page is undergoing an update to improve flexibility when client phone numbers are not available. We have temporarily disabled the "I WANT TO MANAGE" feature in Client Management until the update is complete. We plan to enable the "I WANT TO MANAGE" feature Thursday, January 6. Please see the Help Center article for additional details: https://helpcenter.sureprep.com/hc/en-us/articles/4417892983063
Posted Jan 04, 2022 - 08:17 PST
This incident affected: TaxCaddy (TaxCaddy Dashboard).