SurePrep FileRoom Connectivity Issues
Incident Report for SurePrep
Resolved
The connectivity issues impacting some customers have been resolved. We continue to monitor the situation. Incident updates will be posted here as we get them.
Posted 9 months ago. Oct 12, 2018 - 16:14 PDT
Investigating
Some customers are reporting connectivity issues. We are working to identify and resolve the issues immediately. Incident updates will be posted here as we get them.
Posted 9 months ago. Oct 12, 2018 - 15:47 PDT
This incident affected: FileRoom.