TaxCaddy System Email Delivery Delays
Incident Report for SurePrep
Resolved
The TaxCaddy email deliverability issues have been resolved and all queued emails have been delivered.
Posted over 1 year ago. Mar 30, 2018 - 22:11 PDT
Monitoring
TaxCaddy's vendor/partner for system emails is experiencing deliverability delays. We are monitoring the situation and we will report updates as we receive them.
Posted over 1 year ago. Mar 30, 2018 - 09:39 PDT