SPbinder issues
Incident Report for SurePrep
Resolved
The issue preventing some binders from being opened has been resolved. We apologize for the inconvenience. If there are any system changes, incident updates will be posted here.
Posted 4 months ago. Apr 07, 2019 - 20:09 PDT
Identified
Some customers are reporting that they are unable to open binders. We have identified the cause and we are working to resolve the issue immediately. We apologize for the inconvenience. Incident updates will be posted here as we get them.
Posted 4 months ago. Apr 07, 2019 - 17:53 PDT
This incident affected: SPbinder.