SurePrep Support Systems (Zendesk) - Degraded Performance Announcement
Incident Report for SurePrep
Resolved
SurePrep Support's ticketing system and Help Center (Zendesk) performance issues have been resolved.
Posted 12 months ago. Aug 08, 2018 - 11:46 PDT
Investigating
SurePrep Support's ticketing system and Help Center provider (Zendesk) is currently experiencing intermittent performance issues which are affecting access to the SurePrep Help Center. If you are unable to access the SurePrep Help Center we suggest you send support requests to support@sureprep.com. Incident updates will be posted here as we get them.
Posted 12 months ago. Aug 08, 2018 - 09:13 PDT
This incident affected: Third Party Services (Zendesk (SurePrep Support Ticketing System and Help Center)).