SPbinder Issue
Incident Report for SurePrep
Resolved
The SPbinder issue has been resolved. We continue to closely monitor the situation. If the system status changes, incident updates will be posted here: https://status.sureprep.com.
Posted Apr 12, 2021 - 09:31 PDT
Investigating
Some customers are reporting an error when attempting to open binders. SurePrep engineers are investigating. Incident updates will be posted here https://status.sureprep.com
Posted Apr 12, 2021 - 08:51 PDT
This incident affected: SPbinder.