TaxCaddy Outage
Incident Report for SurePrep
Resolved
The issues causing the “Oops” page have been resolved.
Posted about 2 months ago. Jun 05, 2019 - 10:22 PDT
Investigating
Some customers are reporting an “Oops” page when trying to access TaxCaddy. We are working to identify the cause and resolve the issue immediately. Updates will be posted here as we get them.
Posted about 2 months ago. Jun 05, 2019 - 08:23 PDT
This incident affected: TaxCaddy (TaxCaddy Dashboard).